Page 1 of 1

Crash with studio version on 10.2.8

Posted: Wed Dec 15, 2004 1:25 am
by detlev

i upgraded to the studio version and i used this file: SFD-6.4.0r9(Kodak).
When i am trying to use AACO, SilverFast will crash in the moment,
when AACO does his job (or in this case not ...). The rest you
can perhaps see in the crashlog. (Scanning without AACO works.)

Maybe this is not a SilverFast problem. I found hints to delete
the plist-files and to start checking the permissions with disk aid. But this
don't help. I found also a hint to reinstall the 10.2.8 update, but i
don't do it in the moment.

Is here anyone with the same problem and perhaps a solution?



Date/Time: 2004-12-14 22:25:23 +0100
OS Version: 10.2.8 (Build 6R73)
Host: apple.local.

Command: SF Launcher
PID: 502

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_INVALID_ADDRESS (0x0001) at 0xbff34bd0

Thread 0 Crashed:
#0 0x01f04b24 in 0x1f04b24
#1 0x01ff3ed8 in descratchPerformScanToFile__FP14ScanParameters16descratchSourc
#2 0x01f18444 in 0x1f18444
#3 0x01fa0d10 in writeFileOut(fileTypeEnum, short, unsigned char *, long, long, unsigned char)
#4 0x01f97a38 in writeTiffBatch(void)
#5 0x01f346d0 in 0x1f346d0
#6 0x01f298d0 in HandleSilverFastEvent(EventRecord *)
#7 0x01f28eec in SilverFast_EventLoop(void)
#8 0x01e237cc in 0x1e237cc
#9 0x01de81b8 in main
#10 0x001e337c in callAcquireProc(void (*)(short, AcquireRecord *, long *, short *), short, AcquireRecord *, long *)
#11 0x001e1bf4 in doOneAcquire(void (*)(short, AcquireRecord *, long *, short *))
#12 0x001e1990 in doAcquire(FSSpec)
#13 0x001e567c in callPlugin(OpaqueDialogPtr *)
#14 0x001e5710 in startPlugin(OpaqueDialogPtr *, SF_App_ModeT)
#15 0x001e431c in doMainDialog(void)
#16 0x001e3b18 in main

PPC Thread State:
srr0: 0x01f04b24 srr1: 0x0200f030 vrsave: 0x00000000
xer: 0x20000000 lr: 0x01f04b08 ctr: 0x00000000 mq: 0x00000000
r0: 0xbfffb4a0 r1: 0xbfffad80 r2: 0x02421000 r3: 0xbfffd16c
r4: 0x000006f0 r5: 0x0000049c r6: 0x000014d0 r7: 0x00000008
r8: 0x0000001a r9: 0x00000031 r10: 0x00000034 r11: 0xfff39e50
r12: 0xbfffb684 r13: 0x00000000 r14: 0x00000000 r15: 0x0000004c
r16: 0x00000000 r17: 0x00000400 r18: 0x00000016 r19: 0x00000400
r20: 0x5449464c r21: 0x0000004c r22: 0x00000001 r23: 0x00000061
r24: 0x0000004d r25: 0x026d01f8 r26: 0x026be488 r27: 0x026d0260
r28: 0x02b8b200 r29: 0x02b8b200 r30: 0x02445080 r31: 0xbfffad80

Posted: Tue Dec 21, 2004 10:01 am
by LSI_Noack
Dear Detlev

please don't hesitate to contact LaserSoft Imaging support staff:

I would appreciate if you could paste a fresh copy of the SF_Logfile in the problem report.

On a Mac OS X PC you will find the SF_Logfile in /Users/(your username)/Library/Preferences/LaserSoft Imaging.

You could of course also you the search function of your system to find the "SF_Logfile". The SF_Logfile is always created anew when SilverFast is started up, even if no scanner can be found, it will be created.

Simply open it with your text editor (double clicking the SF_Logfile) and select all the text (CMD+A). Then copy the selection to the clipboard (CMD+C).
Go back to the problem report and click inside the text field. Move the text cursor to the end of your problem description and insert the SF_Logfile from the clipboard (CMD+V).

Thanks in advance for your co-operation.

Kind regards
Sonny Noack
- technical support, LSI AG -

Posted: Thu Dec 23, 2004 6:37 pm
by detlev
Ok, i have filled out the problemreport.

Meanwhile i do the update to 10.2.8 again. This doesn't help.

I have i similar problem with Roxio Toast. I have always to
reinstall the application and can use it only one time.

Posted: Fri Dec 24, 2004 3:16 pm
by detlev
I see a new version 6.4.0r9b. Well, i download it for Kodak RFS 3600, but it is linked with a wrong product, the Kodak links is for a PIE-Scanner. I tried it, my serial number don't work, but it can access the scanner in demo mode. And i have the same effect: With AACO it crashed.
"Normal" scanning works.

Posted: Wed Feb 02, 2005 11:23 am
by LSI_Noack
Dear Detlev

the link is actually correct. The SF for Kodak plug-in has been merged in the SF AFL plug-in. However, you might need a new serial number for using that one.
Don't hesitate to contact support, if you haven't done already.

Kind regards
Sonny Noack
- technical support, LSI AG -

Posted: Wed Feb 02, 2005 11:47 am
by detlev
The problem with the serial number is solved (Ticket#: 2005010610000325). But my MacOS problem still exists. AACO crashed always and also Roxio Toast will not start. I looked the last days for solutions, but now i think, i have to reinstall the whole OS ...

Posted: Wed Feb 02, 2005 2:17 pm
by LSI_Noack
Dear Detlev

while we cannot do anything about Roxio (interference quite unlikely, if not impossible), please don't hesitate to open another ticket via the problem report form:
to get rid of the AACO trouble.

Kind regards
Sonny Noack
- technical support, LSI AG -

Posted: Wed Feb 02, 2005 2:42 pm
by detlev

Posted: Tue Mar 08, 2005 9:58 am
by detlev
Reinstalling the MacOS doesn?t help. The Studio extensions will not run in my environment. I have send an email to the support.

Posted: Tue May 03, 2005 9:13 pm
by detlev
Problems solved with version SFD-6.4.1r7d(AFL).

Thank you.