Installing Scanner & Silverfast in Windows 7 64b

All the problems with Plustek film scanners

casperlux
Visitor
Posts: 3
Joined: Wed Feb 10, 2010 11:45 pm
Scanner: Plustek Optifilm 7500i
SilverFast Product: Ai Studio
SilverFast Version: 6.6

Installing Scanner & Silverfast in Windows 7 64b

Postby casperlux » Thu Feb 11, 2010 12:08 am

Originally bought Plustek 7500i Ai for Win 98 System bundled with Silverscan UScan 6.6.0r2. Worked brilliantly - No Probs.
Bought new Computer with Windows 7 (64b), Got updates for Plustek Driver Software - Installed this and the Original Silverfast software (as above). Warning came up about getting 64b drivers if Scanner not recognised - Exactly what happened. I have just downloaded the Silverscan Upgrade for 64b and hopefully this will work.

I am just about to try again with the upgraded software but is there anyone out there who has done this themselves and can maybe give me tips.

It just seems to be a mission to get the Plustek Drivers installed as it should be done with scanner attached (according to the paperwork) - Windows 7 trys to install driver (and fails) without allowing me to select driver location options. If I install driver package without scanner connected, it is not recognised and will not function even on quickscan. I know this is a Plustek problem really but it does not recognise the installed Silverfast and Silverfast does not see the scanner either so they are kind-of linked. > Thanks

LSI_Luebker
SilverFast Master
SilverFast Master
Posts: 591
Joined: Mon May 07, 2007 9:43 am

Re: Installing Scanner & Silverfast in Windows 7 64b

Postby LSI_Luebker » Mon Feb 15, 2010 2:31 pm

Dear Customer,
basically Windows 7 64Bit and the Plustek 7500i should work fine together if you have installed the current Plustek driver for the Scaner from www.plustek.com and the latest version of SilverFast from our Website.
The Documentation absolutely right when pointing out that the Scanner actually needs to be unplugged when installing the driver.
best regards,

Thomas Luebker,
LaserSoft Imaging AG

casperlux
Visitor
Posts: 3
Joined: Wed Feb 10, 2010 11:45 pm
Scanner: Plustek Optifilm 7500i
SilverFast Product: Ai Studio
SilverFast Version: 6.6

Re: Installing Scanner & Silverfast in Windows 7 64b

Postby casperlux » Sat Mar 06, 2010 10:51 pm

hi Thomas - Thanks for your reply but I had no success. I was a bit puzzled as the Plustek Documentation specifically stated that you connect the Scanner before installing the driver and then use the Windows "New Hardware Detected" setup. The problem I had was that Windows 7 does not seem to let you select different "Find Driver" options. It goes through the setup automatically and then says "Unsuccessful". I tried with the latest drivers in various ways, un-installing between each attempt, without success.

Plustek have very kindly sent me a set of the latest discs so I am going to try again but I still sit with the same dilema. Do I try installing with the Scanner unplugged as you suggested, or do I do what the documentation says and connect the scanner first.

I will post a reply with my results - Successfull or Not

Thanks again > Mike Elliott

casperlux
Visitor
Posts: 3
Joined: Wed Feb 10, 2010 11:45 pm
Scanner: Plustek Optifilm 7500i
SilverFast Product: Ai Studio
SilverFast Version: 6.6

Re: Installing Scanner & Silverfast in Windows 7 64b

Postby casperlux » Sat Mar 06, 2010 11:59 pm

Hi Thomas - Success.

However a note that might be usefull for the Confused.

Windows 7 does not easily let you select drivers or use installation discs. You can Select "Run" and enter "hdwwiz" which opens up a similar window to the old "Install Driver" window we are used to and can be used for straight forward Driver locations but does not seem to work with many "auto-run Product Supplied Discs".

My attempts at Driver installation before connecting Scanner did not work so, after uninstalling everything - I connected the Scanner (as per the Instructions), allowed Windows to Unsuccessfully install the driver, then immediatly ran the DVD and allowed it to Autorun and Install the driver. In Device Manager I found Two drivers were installed and deleted the one that wasn't working and everthing now works fine.

By for now - I am sure I will be asking more questions to get the best out of Silverfast > Mike

LSI_Luebker
SilverFast Master
SilverFast Master
Posts: 591
Joined: Mon May 07, 2007 9:43 am

Re: Installing Scanner & Silverfast in Windows 7 64b

Postby LSI_Luebker » Mon Mar 08, 2010 9:40 am

Thank you for the feedback :-)
best regards,

Thomas Luebker,
LaserSoft Imaging AG

Gabrielle
Visitor
Posts: 1
Joined: Thu Jul 11, 2013 3:37 pm
Scanner: Plustek OpticFilm 7300
SilverFast Product: SE Plus
SilverFast Version: 6.6

Re: Installing Scanner & Silverfast in Windows 7 64b

Postby Gabrielle » Thu Jul 11, 2013 4:01 pm

I am having a very similar problem running Windows 7 Pro 64-bit with a Plustek OpticFilm 7300 and the latest download of SilverFast 6.6.2r5.
The scanner shows in Device Manager as having the latest drivers and the Plustek QuickScan button on the device works OK sending an image to the Desktop, therefore the scanner would appear to be operating normally. The problem is when I install the downloaded the recommended update of SilverFast 6.6.2r5. I get the following message:
"There was no scanner found! Check that your scanner is properly connected to your computer and is switched on. If SilverFast still can't find your scanner, please refer to the logfile SF_LogFile.txt" inside your SilverFast folder", no such folder exists there.
I have tried installing with the scanner turned off, then with scanner turned on, with 32-bit then 64-bit Plustek drivers, with SilverFast 6.5, uninstalling and rebooting the system between each installation. The scanner with Silverfast 6.5 worked fine on my previous Windows 7 Pro 64-bit PC, my current PC is a brand new system so I cannot work out where the problem lies. I have spent a whole day on it, please can someone help and provide a step by step procedure!

User avatar
LSI_Ketelhohn
LSI Staff
LSI Staff
Posts: 4283
Joined: Wed May 28, 2008 11:19 am
Scanner: all
Location: Kiel, Germany
Contact:

Re: Installing Scanner & Silverfast in Windows 7 64b

Postby LSI_Ketelhohn » Tue Jul 16, 2013 4:28 pm

Dear customer,

SilverFast 6.6 is still a32 Bit software and requires the 32 bit driver.
When installing it make sure you only extract the 32 bit folder from the downloaded archive.
This is important because the installer will use the 64 bit driver if it detects the 64 bit folder even if the installer from within the 32bit folder was used.

We also now offer SilverFast 8.0 which is available for your device in 64 bit.
You can obtain it at a 50% discount from our online shop by entering your existing serial number.

kind regards,
Arne Ketelhohn.

biggles93
Visitor
Posts: 2
Joined: Thu Dec 19, 2013 1:45 pm
Scanner: Optic Film 7200
SilverFast Product: SE Plus
SilverFast Version: 6.5

Re: Installing Scanner & Silverfast in Windows 7 64b

Postby biggles93 » Thu Dec 19, 2013 2:32 pm

I have a Plustek Opicfilm 7200 and Silverfast SE Plus 4.1r9b, since 2007.
New computer is Windows7 64 bit and scanned images now have "LaserSoft Imaging" all over them.
Is my scanner obsolete or should upgrading to Silverfast 8 solve the problem?
Alan B

User avatar
LSI_Ketelhohn
LSI Staff
LSI Staff
Posts: 4283
Joined: Wed May 28, 2008 11:19 am
Scanner: all
Location: Kiel, Germany
Contact:

Re: Installing Scanner & Silverfast in Windows 7 64b

Postby LSI_Ketelhohn » Tue Dec 31, 2013 9:20 am

Dear Alan,

Your scanner is still supported in Windows 7 64.
However that operating system requires at least SilverFast 6.6.
Older SilverFast versions can not handle the Windows rights management and folder structure.

kind regards,
Arne Ketelhohn.

biggles93
Visitor
Posts: 2
Joined: Thu Dec 19, 2013 1:45 pm
Scanner: Optic Film 7200
SilverFast Product: SE Plus
SilverFast Version: 6.5

Re: Installing Scanner & Silverfast in Windows 7 64b

Postby biggles93 » Tue Dec 31, 2013 2:23 pm

Many thanks.
Have purchased Se Plus 6.6.2r5.
Hope to post successful installation next year!
Biggles93

timber
Visitor
Posts: 5
Joined: Thu Feb 06, 2014 4:55 am
Scanner: Plustek 7500i
SilverFast Product: Ai
SilverFast Version: 6.5

Re: Installing Scanner & Silverfast in Windows 7 64b

Postby timber » Thu Feb 06, 2014 5:17 am

I have a Plustek OpticFilm 7500i AI and have been trying to install it on on my Win7 (64) computer without success, despite many days spent on the task. It came with SilverFast 6.5, and I now understand this should be upgraded to v8. My problem is getting my computer to recognise the scanner. The instructions say to connect the scanner first, and the computer recognises it as a fim scanner, but whatever I try I cannot get it to recognise it by name (ie Plustek 7500i). I have downloaded the drivers from Plustek but this makes no difference. The scanner will work if I press the QuickScan button, but only produces low resolution negative images from positive slides! No Quickscan Setting menu appears.

Looking at previous posts, I can see that others have had similar problems and I would really value some clear instructions on how to overcome this installation problem. Also advice on when SilverFast should be installed, ie before or after all the other installations.

Thanking you in anticipation

User avatar
LSI_Ketelhohn
LSI Staff
LSI Staff
Posts: 4283
Joined: Wed May 28, 2008 11:19 am
Scanner: all
Location: Kiel, Germany
Contact:

Re: Installing Scanner & Silverfast in Windows 7 64b

Postby LSI_Ketelhohn » Mon Feb 10, 2014 2:32 pm

Dear customer,

"Filmscanner" is the correct name for the device in the device manager.

kind regards,
Arne Ketelhohn.

timber
Visitor
Posts: 5
Joined: Thu Feb 06, 2014 4:55 am
Scanner: Plustek 7500i
SilverFast Product: Ai
SilverFast Version: 6.5

Re: Installing Scanner & Silverfast in Windows 7 64b

Postby timber » Wed Feb 19, 2014 12:47 am

Thank you, Arne. Your comments are all very helpful. I have now managed to install my Plustek 7500i Ai scanner on my Win 7 computer in 64 bit mode, and it works fine in Quickscan mode. I now need to upgrade my SilverFast AI Studio 6.5 to SilverFast 8 (64 bit). Even with the 50% discount, AI Studio 8 is quite expensive and I am not sure whether I will need all the features. Will the cheaper SE8 version work with my scanner? Can I update it later if I want to, at reasonable cost? Finally, do I need to have the scanner switched on or off when I download and install version 8?

Regards

Paul Wood

User avatar
LSI_Ketelhohn
LSI Staff
LSI Staff
Posts: 4283
Joined: Wed May 28, 2008 11:19 am
Scanner: all
Location: Kiel, Germany
Contact:

Re: Installing Scanner & Silverfast in Windows 7 64b

Postby LSI_Ketelhohn » Tue Feb 25, 2014 5:39 pm

Dear Paul,

Yes your scanner is also supported by SilverFast SE and SE Plus.
I would recommend purchasing at least SilverFast SE Plus so you can use Multi-Exposure to enhance your scans.
You can of cause test our demo.
It does not matter wether the scanner is switched on or not when you install SilverFast.


kind regards,
Arne Ketelhohn.

timber
Visitor
Posts: 5
Joined: Thu Feb 06, 2014 4:55 am
Scanner: Plustek 7500i
SilverFast Product: Ai
SilverFast Version: 6.5

Re: Installing Scanner & Silverfast in Windows 7 64b

Postby timber » Tue Mar 04, 2014 9:04 am

Dear Arne

Many thanks for your kind advice. I have now purchased SE Plus and am very pleased with it.

Regards

Paul Wood


Return to “Plustek”

Who is online

Users browsing this forum: No registered users and 1 guest