Generic 'Error from epson'

Problems with OSX 10.x

Moderator: LSI_Moeller


seand
Visitor
Posts: 2
Joined: Tue May 19, 2015 9:39 am

Generic 'Error from epson'

Postby seand » Tue May 19, 2015 10:03 am

Hello,
I've got an Epson 11000XL that has exhibited some strange behaviour. For the first few scans it's fast, completing large flatbed 400dpi scans of artwork in one pass. Then it slows down, and starts pausing - I can hear the parts moving, then pausing, then moving, then pausing, etc through the entire scan. It doesn't seem to affect the scans, but does slow them down so that they take far longer to complete.

Recently when this happened, after a few slow scans it stopped working altogether, and Silverfast simply delayed the generic message 'Error from epson'. I tried restarting Silverfast, turning the scanner off and on, unplugging the USB cable and plugging it in again. No luck getting the scanner to work, but when I fired up Epson Scan it worked fine, and after that, Silverfast would work again.

There's very little in the logs visible in console apart from this message:

Code: Select all

18/05/2015 16:30:04.508 SilverFast 8[1192]: modalSession has been exited prematurely - check for a reentrant call to endModalSession:

and this warning which happens every time I do a scan:

Code: Select all

19/05/2015 09:01:59.178 SilverFast 8[1441]: dynamic_cast error 1: Both of the following type_info's should have public visibility.  At least one of them is hidden. 13CsfBitmapBase, 10CsfBitmapTI9CsfPixelTItLj3ELj65535EEE.


Is there any way I can find more information about the 'Error from epson' message or what might have caused it?

Thanks,
Sean

User avatar
LSI_Ketelhohn
LSI Staff
LSI Staff
Posts: 4283
Joined: Wed May 28, 2008 11:19 am
Scanner: all
Location: Kiel, Germany
Contact:

Re: Generic 'Error from epson'

Postby LSI_Ketelhohn » Wed May 20, 2015 1:26 pm

Dear Sean,

The message "Error from EPSON" means that the scanner itself has sent an error message.

In most cases a slow/stopping scan means that the scanner can not deliver it's data fast enough.
Make sure it is connected directly to an USB port.
Do not use an USB-hub, -extension or the FireWire connection.

Also test a different USB cable.

Make sure no other devices make heavy use of the USB bus.
e.g. scanning to an external USB drive.

Also, when scanning transparencies, check that the calibration area is not blocked.
This is located in the first 2-3 cm of the glass plane.
The scanner's holders leave this strip open and there is a scan area guide to keep it clear for large scans.
The guide looks like a long "plastic bone".

The main hard drive should also not be under heavy use to allow fast access.

Are you using any other load intensive software while scanning?
Especially other imaging products like Photoshop can take up a lot of resources.

For more information please tell me which operating system you are using.
It sounds like there also could be an issue accessing the driver correctly.

Kind regards,
Arne Ketelhohn.

seand
Visitor
Posts: 2
Joined: Tue May 19, 2015 9:39 am

Re: Generic 'Error from epson'

Postby seand » Wed May 20, 2015 2:14 pm

Hi Arne,
I'm using OSX 10.10.3 and scanning straight to file on the internal SSD. (8gig ram, plenty of space on the hard drive.) There are no other USB devices, but I did try another USB cable and the error occurred again. Should my next step be replacing the scanner driver?
Thanks,
Sean

User avatar
LSI_Ketelhohn
LSI Staff
LSI Staff
Posts: 4283
Joined: Wed May 28, 2008 11:19 am
Scanner: all
Location: Kiel, Germany
Contact:

Re: Generic 'Error from epson'

Postby LSI_Ketelhohn » Wed May 20, 2015 3:02 pm

Dear Sean,

If you have not updated the EPSON ScanUtility driver already, this is certainly a good idea.

Please also try repairing the disk permissions if you have not done so already.
(Applications -> Utilities -> Disk Utility -> Select main hard drive (e.g.Macintosh HD) -> click repair disk permissions in central menu.)

Kind regards,
Arne Ketelhohn.

drralph
Visitor
Posts: 2
Joined: Fri Jul 31, 2015 3:37 pm
Scanner: Epson V750 Pro
SilverFast Product: Archive Suite

Re: Generic 'Error from epson'

Postby drralph » Fri Jul 31, 2015 3:39 pm

These tips helped me too, Arne. Turns out my external hard drive was not mounted properly. I ejected, and remounted, and the "error from Epson" went away.


Return to “OSX - Problems”

Who is online

Users browsing this forum: No registered users and 1 guest