SF 8 SE Plus won't install on Windows 10 PC

Problems with installing SilverFast

Posts: 1
Joined: Mon Sep 26, 2016 7:58 pm
Scanner: Epson V850
SilverFast Product: SE Plus

SF 8 SE Plus won't install on Windows 10 PC

Postby DaveStroem » Mon Sep 26, 2016 10:56 pm

I recently purchased an Epson V850 scanner that came bundled with SF 8 SE Plus. When I tried to install the software from the disk on my windows 10 PC, it shows a small box saying that it is unpacking the set-up file. When it gets to 100% the box goes away and nothing happens. When I check Task Manager, it shows the SF Installer there with between 24 & 30% of CPU usage. I tried to let it run for quite a while hoping that it was just slowly loading but after 20 minutes I ended the task in Task Manager.

I think there is some conflict between my PC and the software as I was able to get it to set up on a different PC. I have tried rebooting, turning off antivirus and firewalls. I have also downloaded the latest version from the LSI website. None of these have worked.

I don't know what else to try. Any suggestions?


User avatar
LSI Staff
LSI Staff
Posts: 4283
Joined: Wed May 28, 2008 11:19 am
Scanner: all
Location: Kiel, Germany

Re: SF 8 SE Plus won't install on Windows 10 PC

Postby LSI_Ketelhohn » Tue Oct 04, 2016 3:47 pm

Dear Dave,

please try installing the latest update from our website. Our updates are always full installation files.

Kind regards,

Return to “Installation Problems”

Who is online

Users browsing this forum: No registered users and 1 guest