Cannot upgrade: Not valid or already replaced!

Problems with installing SilverFast

Don Day
Visitor
Posts: 1
Joined: Wed Dec 27, 2017 5:28 pm
Scanner: Epson 4990 Photo
SilverFast Product: SE
SilverFast Version: 6.6

Cannot upgrade: Not valid or already replaced!

Postby Don Day » Wed Dec 27, 2017 5:54 pm

Yesterday I finally installed SF SE v.6.4 4.7 (which was downloaded for my CD-less laptop). The registration went fine, but no email contained my new serial number for future web installations. Today I learned from the forum that my version is not expected to run in Windows 10 (although it starts up fine in demo mode), and I receive the subject error message if I try to upgrade. I accept that I may need to "bite the bullet" and purchase an upgrade (although I would still like to try before I buy). Should I not have an email that verifies my registration information for future upgrades?

Thank you in advance.

User avatar
LSI_Ketelhohn
LSI Staff
LSI Staff
Posts: 4283
Joined: Wed May 28, 2008 11:19 am
Scanner: all
Location: Kiel, Germany
Contact:

Re: Cannot upgrade: Not valid or already replaced!

Postby LSI_Ketelhohn » Tue Jan 02, 2018 11:56 am

Dear user,

You can download a current demo version here.

kind regards
Arne


Return to “Installation Problems”

Who is online

Users browsing this forum: No registered users and 1 guest