silverfast AI 8.8 crashes when returning scan to host Progra

Problems with Windows/Mac OS, Photoshop or Twain hosted programs

Moderators: LSI_Moeller, LSI_Ketelhohn

Posts: 3
Joined: Thu Oct 21, 2004 12:52 pm

silverfast AI 8.8 crashes when returning scan to host Progra

Postby gmoss » Sat Feb 20, 2016 1:28 am

Hi: I have a fresh install of Windows 10 (64 bit) on a new machine. I installed Silverfast AI studio Version 8.8.2 (64 bit version) for my Epson perfection 4870 scanner (USB connection). When I run Siverfast as a stand alone program all seems to work well including the saving of the final file. However when I use a program to call the Twain driver to acquire a scan from the Silverfast Twain driver, the scan transfer fails. All goes well with silverfast until the final step when it completes its scan. Siverfast stops working and Windows 10 closes Silverfast down. (I am guessing this is at the transfer from to silverfast to the host program.) This leaves the calling program frozen and I have to close it down. I have tried this with the Epson Twain driver and the Epson WIA Twain drivers and all works well. Only the Silverfast Twain driver fails. I have noted that the Silverfast Twain driver is listed as "Silverfast TWAIN 1.0(32-32)", guess I was expecting a 64 somewhere in the number. I have tried scanning a Black and white image scan of a post-it at low resolution (Web at smallest size) and it did not crash, it just ran for a longtime (Hours) in save mode after scanning and never finished, seemed to hang at 29%. Has anybody else had this problem? Any suggestions?

User avatar
LSI Staff
LSI Staff
Posts: 4283
Joined: Wed May 28, 2008 11:19 am
Scanner: all
Location: Kiel, Germany

Re: silverfast AI 8.8 crashes when returning scan to host Pr

Postby LSI_Ketelhohn » Thu Feb 25, 2016 11:55 am

Dear customer,

This could be memory issue. It is possible the host program starts reserving memory when it receives the image data and there is suddenly not enough free RAM for both applications.
You can set SilverFast's maximum RAM in the preferences' general tab.

Kind regards,
Arne Ketelhohn.

Return to “Host related problems”

Who is online

Users browsing this forum: No registered users and 1 guest