SCSI adapter not found by Silverfast

Problems with Windows/Mac OS, Photoshop or Twain hosted programs

Moderators: LSI_Moeller, LSI_Ketelhohn

Posts: 1
Joined: Sun Feb 17, 2008 4:34 pm

SCSI adapter not found by Silverfast

Postby QDFB » Sun Feb 17, 2008 4:43 pm

I am trying to run Silverfast Ai Studio trial version for a Howtek 4500 on a Vista Premium system, with an Adaptec AHA-2930U SCSI card. Silverfast says that "no SCSI controller detected" on launch, and exits.

The scanner is found by the Adaptec controller (and corrextly reports its SCSI ID, which I have set as 4, but I have tried others as well) and once the OS is booted up, it is also found by Vista (it asks for drivers for the Howtek - of course there are none, but that is not the issue), so the SCSI controler is working fine, its just that Silverfast does not detect it.

The scanner and the same version of Siverfast works fine on a laptop with a SCSI card, but running Win XP. Clearly its a Siverfast issue if the scanner is correctly reported by both the SCSI card on boot and by Vista once that is booted up.

Just to be clear:

1. I am using the latest version of Silverfast Ai trial downloaded yesterday;
2. That same version works fine on a laptop running XP
3. There are no device conflicts etc, and the SCSI card itself I have tried different SCSI addresses.
4. If I attempt to install the Wnaspi layer by ticking that option in Silverfast on install, I get an Application crash, so I assume no ASPI layer is being installed, if it is needed under Vista.

Any ideas?


User avatar
LSI Staff
LSI Staff
Posts: 1432
Joined: Wed Oct 22, 2003 1:30 pm
Location: Kiel, Germany

Postby LSI_Noack » Mon Feb 25, 2008 3:57 pm


please try if deleting the WNASPI32.DLL file from /Program files/SilverFast application and its subfolders. Will this help?

Best regards
Sonny Noack
- Manager Technical Support, LaserSoft Imaging AG -

Return to “Host related problems”

Who is online

Users browsing this forum: No registered users and 1 guest