Can't launch Silverfast

flatbed scanners for Epson

danbar
Visitor
Posts: 2
Joined: Tue Oct 28, 2014 2:41 am
Scanner: Epson Perfection V750 Pro
SilverFast Version: 5.0 or older

Can't launch Silverfast

Postby danbar » Tue Oct 28, 2014 2:47 am

I have an Epson V750 Pro and it came with Silverfast (6.6.2r2). I've been using this setup for a long time with my macbook pro currently running OSX 10.8.5. I haven't used it in a few months, not a lot of film shooting going on. Now I'm unable to get the SF launcher to start the program. The launcher will start but when I click on the button for the version I want to launch it fails. This is all it will do. I'm at a loss for what to do, I think my version is too old to update without paying for a new version but I'm happy with what I have and it's all I need for how little film scanning I do these days. Any help?

User avatar
LSI_Ketelhohn
LSI Staff
LSI Staff
Posts: 4283
Joined: Wed May 28, 2008 11:19 am
Scanner: all
Location: Kiel, Germany
Contact:

Re: Can't launch Silverfast

Postby LSI_Ketelhohn » Tue Oct 28, 2014 2:21 pm

Dear customer,

your version of SilverFast 6 unfortunately does not support the operating system you tried to install it in.
Please upgrade to the latest version of SilverFast 8.0 if you want to use it with this OS.

To learn pricing for an upgrade, please go to our website, follow the "Store" link, and proceed your purchase as if you'd wanted to buy a new product.

Please note the sentence next to the product selection: "If you already got a SilverFast product, you might be eligible for a discount price for a new version by clicking here."
Follow the instructions and keep the serial number for your current product ready to calculate the upgrade prices.

Thanks for your interest in our software products.

Kind regards,
Arne Ketelhohn.

danbar
Visitor
Posts: 2
Joined: Tue Oct 28, 2014 2:41 am
Scanner: Epson Perfection V750 Pro
SilverFast Version: 5.0 or older

Re: Can't launch Silverfast

Postby danbar » Tue Oct 28, 2014 5:14 pm

This version was already on my computer when I upgraded the operating system a few months ago. I can't find my serial number as I installed this a long time ago and since I can not launch silverfast I can't get the serial number from there. Is there any way to find the serial number without being able to launch the program on my computer?

User avatar
LSI_Ketelhohn
LSI Staff
LSI Staff
Posts: 4283
Joined: Wed May 28, 2008 11:19 am
Scanner: all
Location: Kiel, Germany
Contact:

Re: Can't launch Silverfast

Postby LSI_Ketelhohn » Thu Oct 30, 2014 2:52 pm

Dear customer,

I have forwarded your post to our support system.
I will try to find your serial in our system and contact you by e-mail.

Kind regards,
Arne Ketelhohn.


Return to “Epson”

Who is online

Users browsing this forum: No registered users and 1 guest