Page 1 of 1

Clarity on Photoshop compatibility?

Posted: Sun Jun 04, 2017 2:01 pm
by rsleonard
I just installed SiverFast after receiving my Epson V850. I've now upgraded to SiverFast SE Plus 8.0.

I am running Photoshop CC 2017 (64 bit). There is not import plug in showing for SilverFast.

Am I doing something wrong? If so, where can I find proper documentation on how to appropriately install the plug in?

Thank you in advance.

Re: Clarity on Photoshop compatibility?

Posted: Mon Jun 12, 2017 10:52 am
by LSI_Ketelhohn
Dear user,

please make sure you have installed the latest SilverFast update from our website. You require at least SilverFast 8.8 for Photoshop CC.

Kind regards,
Arne