Installing Silverfast/Plustek 7400 on USB 3 Ports

Posts regarding web site functionality

Moderator: Administrator


Hsiebert
Visitor
Posts: 5
Joined: Fri Feb 08, 2013 2:25 am
Scanner: Plustek OpticFilm 7400
SilverFast Product: SE Plus

Installing Silverfast/Plustek 7400 on USB 3 Ports

Postby Hsiebert » Fri Sep 15, 2017 11:29 pm

SilverFast does not recognize my Plustek 7400 scanner. I installed the latest updates for the program as well as the scanner. I can scan with the scanner from the windows device manager/device driver itself but not from SilverFast. I am using Win 10 and a new Dell XPS 1500 laptop. Windows tells me that the scanner is unable to work with USB 3 port and I should try USB 2 instead. I have an USB 2 hub but no direct USB 2 port. I spent more than 8 hours updating anything that might be needing an update on this new laptop. The Device Manager in Win 10 indicates that the best driver has been installed and there are no problems. Here is the message upon starting up SilverFast:

SilverFast was not able to detect any scanner supported by your installed scan module.
Please make sure your scanner is connected and turned on.
When using USB make sure the scanner is connected directly.
Do not use an USB-hub or USB-extension.
Please make sure that your scanner is shown in the Windows device manager, without any warnings.
In case it is not present, please check the cable connection.
For further information, please visit our support system.

Obviously all those concerns have been observed. So far, the only problem I have been able to detect is the USB 3 connectability.

Thanks for any solution.

Hans Siebert
http://www.xlagger.com

User avatar
LSI_Ketelhohn
LSI Staff
LSI Staff
Posts: 4214
Joined: Wed May 28, 2008 11:19 am
Scanner: all
Location: Kiel, Germany
Contact:

Re: Installing Silverfast/Plustek 7400 on USB 3 Ports

Postby LSI_Ketelhohn » Fri Sep 22, 2017 4:49 pm

Dear Mr Siebert,

Please make sure that you have installed the latest driver from the Plustek Website. SilverFast would not be able to use a Microsoft driver.
Also make sure the latest SilverFast version from our website is installed. You require at least SilverFast 8.8 for Windows 10.

USB3 normally does not cause issues. The scanner should be connected directly to your computer. On a desktop PC use one of the rear ports.

It often helps to reconnect the scanner to a different port if it is not detected.

Kins regards,
Arne

Hsiebert
Visitor
Posts: 5
Joined: Fri Feb 08, 2013 2:25 am
Scanner: Plustek OpticFilm 7400
SilverFast Product: SE Plus

Re: Installing Silverfast/Plustek 7400 on USB 3 Ports

Postby Hsiebert » Fri Sep 22, 2017 11:33 pm

I removed (uninstalled) both, Plustek scanner and Silverfast. Then did a chkdsk /F and re-installed both - same as I had before - now it works. I don't know why but that's ok with me.
Thanks for response.
Hans Siebert :D


Return to “About this web site”

Who is online

Users browsing this forum: No registered users and 2 guests